Affichage des articles dont le libellé est SIP. Afficher tous les articles
Affichage des articles dont le libellé est SIP. Afficher tous les articles

mardi 15 mai 2012

World's first HTML5 SIP Client

After the world's first SIP video clients for Android and iOS (early 2009) we are proud to present sipML5 Project. sipML5 is the world's first open source HTML5 SIP client entirely written in javascript for integration in social networks (FaceBook, Twitter, Google+), online games, e-commerce websites... No extension, plugin or gateway is needed. The media stack rely on WebRTC project. The client can be used to connect to any SIP or IMS network from your preferred browser to make and receive audio/video calls and instant messages.

Short but not exhaustive list of supported features:

  • Audio / Video call
  • Instant messaging
  • Presence
  • Call Hold / Resume
  • Explicit Call transfer
  • Multi-line and multi-account
  • Dual-tone multi-frequency signaling (DTMF) using SIP INFO
For more information: http://www.sipml5.org
Call between Google Chrome and iPad device
Call between Google Chrome and Android device

mardi 15 février 2011

OpenVCS - Open Source VideoConferencing Server

We are proud to announce the availability of the first alpha release of OpenVCS.
OpenVCS stands for Open Source Video Conferencing Server and uses SIP (RFC 3261, 3GPP TS 24.229) protocol.
OpenVCS is used as a Multipoint Control Unit (MCU) manager. The application can managed any number of MCU (a.k.a Bridge) where each Bridge can support up to 64 participants.

The application can be used as a standalone SIP server or behind an IMS Core where each Bridge will be seen as an AS (Application Server).
You can use any SIP compliant device to connect to a bridge as long as the client is RFC 3261 compliant. For example, you can use IMSDroid on Android, iDoubs on iOS (iPhone, iPod Touch or iPad), Boghe on Windows or Linphone/Bria on MAC OS X or Linux.



For more information: http://code.google.com/p/openvcs/

lundi 20 décembre 2010

Boghe - IMS/RCS Client for Windows

We are proud to announce the availability of the first alpha release of Boghe, our IMS/RCS client for Windows XP, Vista and 7.



For more information: http://code.google.com/p/boghe/

dimanche 10 octobre 2010

First alpha release of iDoubs

We are proud to announce the availability of the first alpha release of iDoubs. iDoubs is the world's first open source Videophone for iOS (iPhone, iPad and iPod Touch).

mercredi 28 juillet 2010

First beta release of IMSDroid

We are proud to announce the availability of the first beta release of IMSDroid. IMSDroid is the first fully featured open source SIP/IMS client for Android devices.

The current version of IMSDroid partially implements GSMA Rich Communication Suite release 3 and The One Voice profile V1.0.0 (LTE/4G, also known as GSMA VoLTE) specifications. Missing features will be implemented in the next releases. Stay tuned.
Highlights
  • SIP(RFC 3261, 3GPP TS 24.229 Rel-9)
  • Signaling Compression, SigComp (RFC 3320, 3485, 4077, 4464, 4465, 4896, 5049, 5112 and 1951)

  • Enhanced Address Book (XCAP storage, authorizations, presence, ...)
  • Partial supports for GSMA Rich Communication Suite release 3
  • Partial supports for One Voice Profile V1.0.0 (GSMA VoLTE)
  • Partial supports for MMTel UNI (used by GSMA RCS and GSMA VoLTE)

  • IMS-AKA registration (both AKA-v1 and AKA-v2), Digest MD5, Basic
  • 3GPP Early IMS Security (3GPP TS 33.978)
  • Proxy-CSCF discovery using DNS NAPTR+SRV
  • Private extension headers for 3GPP
  • Service Route discovery
  • Subscription to reg event package (Honoring network initiated (re/de/un)-registration events)

  • 3GPP SMS Over IP (3GPP TS 23.038, 24.040, 24.011, 24.341 and 24.451)
  • Voice Call (AMR-NB, GSM, PCMA, PCMU, Speex-NB, iLBC)
  • Video Call (H264, Theora, H.263, H.263-1998, H.261)
  • DTMF (RFC 4733)
  • QoS negotiation using Preconditions (RFC 3312, 4032 and 5027)
  • SIP Session Timers (RFC 4028)
  • Provisional Response Acknowledgments (PRACK)
  • Communication Hold (3GPP TS 24.610)
  • Message Waiting Indication (3GPP TS 24.606)
  • Calling E.164 numbers by using ENUM protocol (RFC 3761)
  • NAT Traversal using STUN2 (RFC 5389) with possibilities to automatically discover the server by using DNS SRV (TURN already implemented and ICE is under tests)





Many other features are supported by the underlying framework but not exposed to the user interface (in progress). For more information please refer to doubango website.
These features include: IPv6, OMA Large IM Message (MSRP), File Transfer (MSRP), Image Sharing (IR.79), Video Sharing (IR.74), TLS and IPSec Security Agreement (RFC 3329), Proxy-CSCF discovery using DHCPv4/v6, TURN, ...

For more information: http://code.google.com/p/imsdroid